0.8.1 and Tomcat 7

classic Classic list List threaded Threaded
2 messages Options
kv8
Reply | Threaded
Open this post in threaded view
|

0.8.1 and Tomcat 7

kv8
This post has NOT been accepted by the mailing list yet.
Great work with 8.1 and support for GWT 2.4 is great. I just deployed our atmosphere servlet under tomcat 7. It throws a not supported error with <async-supported>true</async-supported>, works when I use org.atmosphere.useNative. Is this a known error ?

This is my log after using useNative.
========
15:03:11.474 [pool-2-thread-1] WARN  o.a.cpr.DefaultCometSupportResolver - Found multiple containers, please specify which one to use: org.atmosphere.container.JettyCometSupport, org.atmosphere.container.Tomcat7CometSupport, org.atmosphere.container.TomcatCometSupport,  until you do, Atmosphere will use:class org.atmosphere.container.JettyCometSupport
15:03:11.474 [pool-2-thread-1] INFO  org.atmosphere.cpr.AtmosphereServlet - Atmosphere is using async support: org.atmosphere.container.JettyCometSupport running under container: Apache Tomcat/7.0.23
========

I want to be sure that the Servlet is indeed not blocking. Appreciate the help !!


           
Reply | Threaded
Open this post in threaded view
|

Re: 0.8.1 and Tomcat 7

jfarcand
Administrator
Hi, let's move to

    http://groups.google.com/group/atmosphere-framework

can you paste the exact exception?

Thanks!!!!

-- Jeanfrancois