Error with Tomcat 7.0.16 and atmosphere 0.8-SNAPSHOT

classic Classic list List threaded Threaded
5 messages Options
ale
Reply | Threaded
Open this post in threaded view
|

Error with Tomcat 7.0.16 and atmosphere 0.8-SNAPSHOT

ale
Hello. When i try atmosphere with tomcat 7, atmosphere crash with this exception.

Log


21:48:44.773 INFO [Thread-11] o.a.c.AtmosphereServlet [AtmosphereServlet.java:535] initializing atmosphere framework: 0.8-SNAPSHOT
21:48:44.775 INFO [Thread-11] o.a.c.AtmosphereServlet [AtmosphereServlet.java:410] using default broadcaster class: class org.atmosphere.cpr.DefaultBroadcaster
21:48:44.792 INFO [Thread-11] o.a.c.AtmosphereServlet [AtmosphereServlet.java:877] successfully loaded handler: com.s4s.server.mensajero.AtmosphereHandler@f0691c mapped to context-path: /api/gwt/comet
21:48:44.861 WARN [Thread-11] o.a.c.DefaultCometSupportResolver [DefaultCometSupportResolver.java:272] Found multiple containers, please specify which one to use: org.atmosphere.container.Tomcat7CometSupport, org.atmosphere.container.TomcatCometSupport,  until you do, Atmosphere will use:class org.atmosphere.container.Tomcat7CometSupport
21:48:44.862 INFO [Thread-11] o.a.c.AtmosphereServlet [AtmosphereServlet.java:977] Atmosphere is using comet support: org.atmosphere.container.Tomcat7CometSupport running under container: Apache Tomcat/7.0.16
....
.... (more log)
....
21:49:36.023 WARN ["http-nio-8080"-exec-9] o.a.c.AtmosphereServlet [AtmosphereServlet.java:1170] Tomcat failed to detect this is a Comet application because context.xml is missing or the Http11NioProtocol Connector is not enabled.
If that's not the case, you can also remove META-INF/context.xml and WEB-INF/lib/atmosphere-compat-tomcat.jar
java.lang.IllegalStateException: Tomcat failed to detect this is a Comet application because context.xml is missing or the Http11NioProtocol Connector is not enabled.
If that's not the case, you can also remove META-INF/context.xml and WEB-INF/lib/atmosphere-compat-tomcat.jar
        at org.atmosphere.container.Tomcat7CometSupport.<clinit>(Tomcat7CometSupport.java:45) ~[atmosphere-runtime-0.8-SNAPSHOT.jar:0.8-SNAPSHOT]
        at sun.reflect.NativeConstructorAccessorImpl.newInstance0(Native Method) ~[na:1.6.0_26]
        at sun.reflect.NativeConstructorAccessorImpl.newInstance(NativeConstructorAccessorImpl.java:39) ~[na:1.6.0_26]
        at sun.reflect.DelegatingConstructorAccessorImpl.newInstance(DelegatingConstructorAccessorImpl.java:27) ~[na:1.6.0_26]
        at java.lang.reflect.Constructor.newInstance(Constructor.java:513) ~[na:1.6.0_26]
        at org.atmosphere.cpr.DefaultCometSupportResolver.newCometSupport(DefaultCometSupportResolver.java:187) ~[atmosphere-runtime-0.8-SNAPSHOT.jar:0.8-SNAPSHOT]
        at org.atmosphere.cpr.DefaultCometSupportResolver.resolveMultipleNativeSupportConflict(DefaultCometSupportResolver.java:273) ~[atmosphere-runtime-0.8-SNAPSHOT.jar:0.8-SNAPSHOT]
        at org.atmosphere.cpr.DefaultCometSupportResolver.resolveNativeCometSupport(DefaultCometSupportResolver.java:257) ~[atmosphere-runtime-0.8-SNAPSHOT.jar:0.8-SNAPSHOT]
        at org.atmosphere.cpr.DefaultCometSupportResolver.resolve(DefaultCometSupportResolver.java:222) ~[atmosphere-runtime-0.8-SNAPSHOT.jar:0.8-SNAPSHOT]
        at org.atmosphere.cpr.DefaultCometSupportResolver.resolve(DefaultCometSupportResolver.java:231) ~[atmosphere-runtime-0.8-SNAPSHOT.jar:0.8-SNAPSHOT]
....
.... (more stack)
....
21:49:36.024 WARN ["http-nio-8080"-exec-9] o.a.c.AtmosphereServlet [AtmosphereServlet.java:1173] failed using comet support: org.atmosphere.container.Tomcat7CometSupport, error: Tomcat failed to detect this is a Comet application because context.xml is missing or the Http11NioProtocol Connector is not enabled.
If that's not the case, you can also remove META-INF/context.xml and WEB-INF/lib/atmosphere-compat-tomcat.jar
21:49:36.025 WARN ["http-nio-8080"-exec-9] o.a.c.AtmosphereServlet [AtmosphereServlet.java:1175] Using BlockingIOCometSupport.


MAVEN POM.XML

    <dependency>
      <groupId>org.atmosphere</groupId>
      <artifactId>atmosphere-runtime</artifactId>
      <version>${version.atmosphere}</version>
      <scope>compile</scope>
      <exclusions>
        <exclusion>
          <artifactId>atmosphere-ping</artifactId>
          <groupId>org.atmosphere</groupId>
        </exclusion>
      </exclusions>
    </dependency>
    <dependency>
      <groupId>org.atmosphere</groupId>
      <artifactId>atmosphere-guice</artifactId>
      <version>${version.atmosphere}</version>
      <type>jar</type>
      <scope>compile</scope>
      <exclusions>
        <exclusion>
          <artifactId>guice</artifactId>
          <groupId>com.google.code.guice</groupId>
        </exclusion>
        <exclusion>
          <artifactId>guice-servlet</artifactId>
          <groupId>com.google.code.guice</groupId>
        </exclusion>
        <exclusion>
          <artifactId>guice-servlet</artifactId>
          <groupId>com.google.inject.extensions</groupId>
        </exclusion>
        <exclusion>
          <artifactId>guice</artifactId>
          <groupId>com.google.inject</groupId>
        </exclusion>
        <exclusion>
        <artifactId>javax.servlet</artifactId>
        <groupId>org.glassfish</groupId>
        </exclusion>
      </exclusions>
    </dependency>
    <dependency>
      <groupId>org.atmosphere</groupId>
      <artifactId>atmosphere-jersey</artifactId>
      <version>${version.atmosphere}</version>
      <scope>compile</scope>
    </dependency>
    <dependency>
      <groupId>org.atmosphere</groupId>
      <artifactId>atmosphere-commons</artifactId>
      <version>0.6.5</version>
      <type>jar</type>
      <scope>compile</scope>
    </dependency>

META-INF/CONTEXT.XML AND WEB-INF/CONTEXT.XML

<?xml version="1.0" encoding="UTF-8"?>
<Context>
  <Loader delegate="true" />
</Context>


CUSTOM PROPERTIES

                serve("/api/gwt/*", "/api/rest/*").with(GuiceManagedAtmosphereServlet.class, new HashMap<String, String>() {
                        {
                                put(AtmosphereServlet.PROPERTY_NATIVE_COMETSUPPORT, "true");
                                put(AtmosphereServlet.DISABLE_ONSTATE_EVENT, "true");
                                put(AtmosphereServlet.PROPERTY_SERVLET_MAPPING, "/api/rest/*");
                                put(PackagesResourceConfig.PROPERTY_PACKAGES, "com.s4s.server.mensajero");
                        }
                });

Thanks.

Reply | Threaded
Open this post in threaded view
|

Re: Error with Tomcat 7.0.16 and atmosphere 0.8-SNAPSHOT

survivant
it's not crashing, it's only outputing warning.  JF fixed it in the trunk, but I think he didn't release it in the repositories.

I build the jar from the source, and it's fine now


please folow this thread : http://java.net/jira/browse/ATMOSPHERE-143

it needs a more feedback.




2011/7/25 ale <[hidden email]>
Hello. When i try atmosphere with tomcat 7, atmosphere crash with this
exception.

*Log*


21:48:44.773 INFO [Thread-11] o.a.c.AtmosphereServlet
[AtmosphereServlet.java:535] initializing atmosphere framework: 0.8-SNAPSHOT
21:48:44.775 INFO [Thread-11] o.a.c.AtmosphereServlet
[AtmosphereServlet.java:410] using default broadcaster class: class
org.atmosphere.cpr.DefaultBroadcaster
21:48:44.792 INFO [Thread-11] o.a.c.AtmosphereServlet
[AtmosphereServlet.java:877] successfully loaded handler:
com.s4s.server.mensajero.AtmosphereHandler@f0691c mapped to context-path:
/api/gwt/comet
21:48:44.861 WARN [Thread-11] o.a.c.DefaultCometSupportResolver
[DefaultCometSupportResolver.java:272] Found multiple containers, please
specify which one to use: org.atmosphere.container.Tomcat7CometSupport,
org.atmosphere.container.TomcatCometSupport,  until you do, Atmosphere will
use:class org.atmosphere.container.Tomcat7CometSupport
21:48:44.862 INFO [Thread-11] o.a.c.AtmosphereServlet
[AtmosphereServlet.java:977] Atmosphere is using comet support:
org.atmosphere.container.Tomcat7CometSupport running under container: Apache
Tomcat/7.0.16
....
.... (more log)
....
21:49:36.023 WARN ["http-nio-8080"-exec-9] o.a.c.AtmosphereServlet
[AtmosphereServlet.java:1170] Tomcat failed to detect this is a Comet
application because context.xml is missing or the Http11NioProtocol
Connector is not enabled.
If that's not the case, you can also remove META-INF/context.xml and
WEB-INF/lib/atmosphere-compat-tomcat.jar
java.lang.IllegalStateException: Tomcat failed to detect this is a Comet
application because context.xml is missing or the Http11NioProtocol
Connector is not enabled.
If that's not the case, you can also remove META-INF/context.xml and
WEB-INF/lib/atmosphere-compat-tomcat.jar
       at
org.atmosphere.container.Tomcat7CometSupport.<clinit>(Tomcat7CometSupport.java:45)
~[atmosphere-runtime-0.8-SNAPSHOT.jar:0.8-SNAPSHOT]
       at sun.reflect.NativeConstructorAccessorImpl.newInstance0(Native
Method) ~[na:1.6.0_26]
       at
sun.reflect.NativeConstructorAccessorImpl.newInstance(NativeConstructorAccessorImpl.java:39)
~[na:1.6.0_26]
       at
sun.reflect.DelegatingConstructorAccessorImpl.newInstance(DelegatingConstructorAccessorImpl.java:27)
~[na:1.6.0_26]
       at java.lang.reflect.Constructor.newInstance(Constructor.java:513)
~[na:1.6.0_26]
       at
org.atmosphere.cpr.DefaultCometSupportResolver.newCometSupport(DefaultCometSupportResolver.java:187)
~[atmosphere-runtime-0.8-SNAPSHOT.jar:0.8-SNAPSHOT]
       at
org.atmosphere.cpr.DefaultCometSupportResolver.resolveMultipleNativeSupportConflict(DefaultCometSupportResolver.java:273)
~[atmosphere-runtime-0.8-SNAPSHOT.jar:0.8-SNAPSHOT]
       at
org.atmosphere.cpr.DefaultCometSupportResolver.resolveNativeCometSupport(DefaultCometSupportResolver.java:257)
~[atmosphere-runtime-0.8-SNAPSHOT.jar:0.8-SNAPSHOT]
       at
org.atmosphere.cpr.DefaultCometSupportResolver.resolve(DefaultCometSupportResolver.java:222)
~[atmosphere-runtime-0.8-SNAPSHOT.jar:0.8-SNAPSHOT]
       at
org.atmosphere.cpr.DefaultCometSupportResolver.resolve(DefaultCometSupportResolver.java:231)
~[atmosphere-runtime-0.8-SNAPSHOT.jar:0.8-SNAPSHOT]
....
.... (more stack)
....
21:49:36.024 WARN ["http-nio-8080"-exec-9] o.a.c.AtmosphereServlet
[AtmosphereServlet.java:1173] failed using comet support:
org.atmosphere.container.Tomcat7CometSupport, error: Tomcat failed to detect
this is a Comet application because context.xml is missing or the
Http11NioProtocol Connector is not enabled.
If that's not the case, you can also remove META-INF/context.xml and
WEB-INF/lib/atmosphere-compat-tomcat.jar
21:49:36.025 WARN ["http-nio-8080"-exec-9] o.a.c.AtmosphereServlet
[AtmosphereServlet.java:1175] Using BlockingIOCometSupport.


*MAVEN POM.XML*

   <dependency>
     <groupId>org.atmosphere</groupId>
     <artifactId>atmosphere-runtime</artifactId>
     <version>${version.atmosphere}</version>
     <scope>compile</scope>
     <exclusions>
       <exclusion>
         <artifactId>atmosphere-ping</artifactId>
         <groupId>org.atmosphere</groupId>
       </exclusion>
     </exclusions>
   </dependency>
   <dependency>
     <groupId>org.atmosphere</groupId>
     <artifactId>atmosphere-guice</artifactId>
     <version>${version.atmosphere}</version>
     <type>jar</type>
     <scope>compile</scope>
     <exclusions>
       <exclusion>
         <artifactId>guice</artifactId>
         <groupId>com.google.code.guice</groupId>
       </exclusion>
       <exclusion>
         <artifactId>guice-servlet</artifactId>
         <groupId>com.google.code.guice</groupId>
       </exclusion>
       <exclusion>
         <artifactId>guice-servlet</artifactId>
         <groupId>com.google.inject.extensions</groupId>
       </exclusion>
       <exclusion>
         <artifactId>guice</artifactId>
         <groupId>com.google.inject</groupId>
       </exclusion>
       <exclusion>
               <artifactId>javax.servlet</artifactId>
               <groupId>org.glassfish</groupId>
       </exclusion>
     </exclusions>
   </dependency>
   <dependency>
     <groupId>org.atmosphere</groupId>
     <artifactId>atmosphere-jersey</artifactId>
     <version>${version.atmosphere}</version>
     <scope>compile</scope>
   </dependency>
   <dependency>
     <groupId>org.atmosphere</groupId>
     <artifactId>atmosphere-commons</artifactId>
     <version>0.6.5</version>
     <type>jar</type>
     <scope>compile</scope>
   </dependency>

*META-INF/CONTEXT.XML AND WEB-INF/CONTEXT.XML*

<?xml version="1.0" encoding="UTF-8"?>
<Context>
 <Loader delegate="true" />
</Context>


*CUSTOM PROPERTIES*

               serve("/api/gwt/*",
"/api/rest/*").with(GuiceManagedAtmosphereServlet.class, new
HashMap&lt;String, String&gt;() {
                       {
                               put(AtmosphereServlet.PROPERTY_NATIVE_COMETSUPPORT, "true");
                               put(AtmosphereServlet.DISABLE_ONSTATE_EVENT, "true");
                               put(AtmosphereServlet.PROPERTY_SERVLET_MAPPING, "/api/rest/*");
                               put(PackagesResourceConfig.PROPERTY_PACKAGES,
"com.s4s.server.mensajero");
                       }
               });

Thanks.



--
View this message in context: http://atmosphere-users-mailling-list.2493822.n2.nabble.com/Error-with-Tomcat-7-0-16-and-atmosphere-0-8-SNAPSHOT-tp6620744p6620744.html
Sent from the Atmosphere users mailling list mailing list archive at Nabble.com.



--
-------------
A+

Sébastien.

Vous pouvez me suivre sur Twitter / You can follow me on Twitter : http://twitter.com/survivant
ale
Reply | Threaded
Open this post in threaded view
|

Re: Error with Tomcat 7.0.16 and atmosphere 0.8-SNAPSHOT

ale
Thanks for the quick answer. You're right, there is no a crash is a warning.

I think I'll have to wait for the next release.

ale
Reply | Threaded
Open this post in threaded view
|

Re: Error with Tomcat 7.0.16 and atmosphere 0.8-SNAPSHOT

ale
I'm using atmosphere-compat-tomcat-0.8-20110808.165107-45 with tomcat 7.0.20 and i still have this issues.

Plz any feedback for this issues ?.. Next week we go into production and I do not want to use BlockingIOCometSupport.
Reply | Threaded
Open this post in threaded view
|

Re: Error with Tomcat 7.0.16 and atmosphere 0.8-SNAPSHOT

idlemind
This post has NOT been accepted by the mailing list yet.
I´m trying to get jquery-pubsub sample working on eclipse using the tomcat version apache-tomcat-7.0.25 installed fresh from apache. I would really like to try out Nettosphere but think of getting it first running on tomcat.

When trying to run index.html on tomcat in eclipse, I get the follwon output. My concern is Comet application because context.xml is missing or the Http11NioProtocol Connector is not enabled

Can you help me which what file i need to modify and what line to add in tat file please.


Mar 3, 2012 9:44:58 PM org.apache.catalina.core.AprLifecycleListener init
INFO: The APR based Apache Tomcat Native library which allows optimal performance in production environments was not found on the java.library.path: C:\Program Files\Java\jdk1.6.0_30\bin;C:\Windows\Sun\Java\bin;C:\Windows\system32;C:\Windows;C:/Program Files/Java/jdk1.6.0_30/bin/../jre/bin/client;C:/Program Files/Java/jdk1.6.0_30/bin/../jre/bin;C:/Program Files/Java/jdk1.6.0_30/bin/../jre/lib/i386;C:\Program Files\Java\jdk1.6.0_30\bin;C:\Windows\system32;C:\Windows;C:\Windows\System32\Wbem;C:\Program Files\Common Files\Lenovo;C:\Program Files\Intel\WiFi\bin\;C:\Program Files\Common Files\Intel\WirelessCommon\;C:\Program Files\ThinkPad\Bluetooth Software\;C:\Windows\System32\WindowsPowerShell\v1.0\;C:\Program Files\Git\cmd;C:\Users\vikrant\AppData\Roaming\npm;C:\Program Files\nodejs\;C:\Program Files\nodejs\node_modules\;C:\npm\node_modules;C:\My\ProjectWork\Software\apache-maven-3.0.4\bin;C:\Program Files\Java\jdk1.6.0_30\bin;C:\My\ProjectWork\Software\eclipse;;.
Mar 3, 2012 9:44:58 PM org.apache.tomcat.util.digester.SetPropertiesRule begin
WARNING: [SetPropertiesRule]{Server/Service/Engine/Host/Context} Setting property 'source' to 'org.eclipse.jst.jee.server:atmosphere-jquery-pubsub' did not find a matching property.
Mar 3, 2012 9:44:58 PM org.apache.coyote.AbstractProtocol init
INFO: Initializing ProtocolHandler ["http-bio-8080"]
Mar 3, 2012 9:44:58 PM org.apache.coyote.AbstractProtocol init
INFO: Initializing ProtocolHandler ["ajp-bio-8009"]
Mar 3, 2012 9:44:58 PM org.apache.catalina.startup.Catalina load
INFO: Initialization processed in 487 ms
Mar 3, 2012 9:44:58 PM org.apache.catalina.core.StandardService startInternal
INFO: Starting service Catalina
Mar 3, 2012 9:44:58 PM org.apache.catalina.core.StandardEngine startInternal
INFO: Starting Servlet Engine: Apache Tomcat/7.0.25
21:44:58.980 [pool-2-thread-1] INFO  org.atmosphere.cpr.AtmosphereServlet - Using BroadcasterFactory class: org.atmosphere.cpr.DefaultBroadcasterFactory
21:44:58.992 [pool-2-thread-1] INFO  org.atmosphere.cpr.AtmosphereServlet - Auto detecting atmosphere handlers /WEB-INF/classes/
21:44:59.005 [pool-2-thread-1] WARN  org.atmosphere.cpr.AtmosphereServlet - Missing META-INF/atmosphere.xml but found the Jersey runtime. Starting Jersey
21:44:59.011 [pool-2-thread-1] INFO  org.atmosphere.cpr.AtmosphereServlet - Using BroadcasterFactory class: org.atmosphere.cpr.DefaultBroadcasterFactory
21:44:59.030 [pool-2-thread-1] INFO  org.atmosphere.cpr.AtmosphereServlet - Installed AtmosphereHandler org.atmosphere.handler.ReflectorServletProcessor mapped to context-path: /*
21:44:59.043 [pool-2-thread-1] WARN  o.a.cpr.DefaultCometSupportResolver - Found multiple containers, please specify which one to use: org.atmosphere.container.Tomcat7CometSupport, org.atmosphere.container.TomcatCometSupport,  until you do, Atmosphere will use:class org.atmosphere.container.Tomcat7CometSupport
21:44:59.044 [pool-2-thread-1] INFO  org.atmosphere.cpr.AtmosphereServlet - Atmosphere is using async support: org.atmosphere.container.Tomcat7CometSupport running under container: Apache Tomcat/7.0.25
21:44:59.060 [pool-2-thread-1] INFO  o.a.h.ReflectorServletProcessor - Installing Servlet com.sun.jersey.spi.container.servlet.ServletContainer
Mar 3, 2012 9:44:59 PM com.sun.jersey.api.core.servlet.WebAppResourceConfig init
INFO: Scanning for root resource and provider classes in the Web app resource paths:
  /WEB-INF/lib
  /WEB-INF/classes
Mar 3, 2012 9:44:59 PM com.sun.jersey.api.core.ScanningResourceConfig logClasses
INFO: Root resource classes found:
  class org.atmosphere.samples.pubsub.FileResource
  class org.atmosphere.samples.pubsub.JQueryPubSub
Mar 3, 2012 9:44:59 PM com.sun.jersey.api.core.ScanningResourceConfig init
INFO: No provider classes found.
Mar 3, 2012 9:44:59 PM com.sun.jersey.server.impl.application.WebApplicationImpl _initiate
INFO: Initiating Jersey application, version 'Jersey: 1.10 11/02/2011 03:53 PM'
Mar 3, 2012 9:44:59 PM com.sun.jersey.server.impl.application.WebApplicationImpl _initiate
INFO: Adding the following classes declared in META-INF/services/jersey-server-components to the resource configuration:
  class org.atmosphere.jersey.AtmosphereResourceConfigurator
21:44:59.945 [pool-2-thread-1] DEBUG o.atmosphere.jersey.AtmosphereFilter - AtmosphereFilter processing annotation: @javax.ws.rs.Path(value=/jquery/{id})
21:44:59.945 [pool-2-thread-1] DEBUG o.atmosphere.jersey.AtmosphereFilter - AtmosphereFilter processing annotation: @javax.ws.rs.GET()
21:44:59.968 [pool-2-thread-1] DEBUG o.atmosphere.jersey.AtmosphereFilter - AtmosphereFilter processing annotation: @javax.ws.rs.GET()
21:44:59.989 [pool-2-thread-1] DEBUG o.atmosphere.jersey.AtmosphereFilter - AtmosphereFilter processing annotation: @javax.ws.rs.GET()
21:44:59.991 [pool-2-thread-1] DEBUG o.atmosphere.jersey.AtmosphereFilter - AtmosphereFilter processing annotation: @javax.ws.rs.POST()
21:44:59.991 [pool-2-thread-1] DEBUG o.atmosphere.jersey.AtmosphereFilter - AtmosphereFilter processing annotation: @org.atmosphere.annotation.Broadcast(writeEntity=true, resumeOnBroadcast=false, value=[], delay=-1)
21:45:00.013 [pool-2-thread-1] DEBUG o.atmosphere.jersey.AtmosphereFilter - AtmosphereFilter processing annotation: @javax.ws.rs.Produces(value=[application/xml])
21:45:00.013 [pool-2-thread-1] DEBUG o.atmosphere.jersey.AtmosphereFilter - AtmosphereFilter processing annotation: @javax.ws.rs.GET()
21:45:00.013 [pool-2-thread-1] DEBUG o.atmosphere.jersey.AtmosphereFilter - AtmosphereFilter processing annotation: @javax.ws.rs.Path(value={path})
21:45:00.015 [pool-2-thread-1] DEBUG o.atmosphere.jersey.AtmosphereFilter - AtmosphereFilter processing annotation: @javax.ws.rs.Produces(value=[application/vnd.sun.wadl+xml, application/xml])
21:45:00.015 [pool-2-thread-1] DEBUG o.atmosphere.jersey.AtmosphereFilter - AtmosphereFilter processing annotation: @javax.ws.rs.GET()
21:45:00.027 [pool-2-thread-1] INFO  org.atmosphere.cpr.AtmosphereServlet - Using broadcaster class: org.atmosphere.jersey.JerseyBroadcaster
21:45:00.029 [pool-2-thread-1] INFO  org.atmosphere.cpr.AtmosphereServlet - Atmosphere Framework 0.9.0.alpha.v20120301 started.
Mar 3, 2012 9:45:00 PM org.apache.coyote.AbstractProtocol start
INFO: Starting ProtocolHandler ["http-bio-8080"]
Mar 3, 2012 9:45:00 PM org.apache.coyote.AbstractProtocol start
INFO: Starting ProtocolHandler ["ajp-bio-8009"]
Mar 3, 2012 9:45:00 PM org.apache.catalina.startup.Catalina start
INFO: Server startup in 1531 ms
21:45:00.553 [http-bio-8080-exec-3] WARN  org.atmosphere.cpr.AtmosphereServlet - Failed using comet support: org.atmosphere.container.Tomcat7CometSupport, error: Tomcat failed to detect this is a Comet application because context.xml is missing or the Http11NioProtocol Connector is not enabled.
If that's not the case, you can also remove META-INF/context.xml and WEB-INF/lib/atmosphere-compat-tomcat.jar Is the Nio or Apr Connector enabled?
21:45:00.553 [http-bio-8080-exec-3] WARN  org.atmosphere.cpr.AtmosphereServlet - Using BlockingIOCometSupport.
Mar 3, 2012 10:14:23 PM org.apache.catalina.core.StandardServer await
INFO: A valid shutdown command was received via the shutdown port. Stopping the Server instance.
Mar 3, 2012 10:14:23 PM org.apache.coyote.AbstractProtocol pause
INFO: Pausing ProtocolHandler ["http-bio-8080"]
Mar 3, 2012 10:14:23 PM org.apache.coyote.AbstractProtocol pause
INFO: Pausing ProtocolHandler ["ajp-bio-8009"]
Mar 3, 2012 10:14:23 PM org.apache.catalina.core.StandardService stopInternal
INFO: Stopping service Catalina
22:14:23.801 [pool-2-thread-2] DEBUG o.a.cpr.DefaultBroadcasterFactory - Removing Broadcaster /* factory size now 0
Mar 3, 2012 10:14:23 PM org.apache.coyote.AbstractProtocol stop
INFO: Stopping ProtocolHandler ["http-bio-8080"]
Mar 3, 2012 10:14:23 PM org.apache.coyote.AbstractProtocol stop
INFO: Stopping ProtocolHandler ["ajp-bio-8009"]
Mar 3, 2012 10:14:23 PM org.apache.coyote.AbstractProtocol destroy
INFO: Destroying ProtocolHandler ["http-bio-8080"]
Mar 3, 2012 10:14:23 PM org.apache.coyote.AbstractProtocol destroy
INFO: Destroying ProtocolHandler ["ajp-bio-8009"]
ale wrote
I'm using atmosphere-compat-tomcat-0.8-20110808.165107-45 with tomcat 7.0.20 and i still have this issues.

Plz any feedback for this issues ?.. Next week we go into production and I do not want to use BlockingIOCometSupport.