atmosphere-runtime and JRE 1.5

classic Classic list List threaded Threaded
5 messages Options
Reply | Threaded
Open this post in threaded view
|

atmosphere-runtime and JRE 1.5

Nicolas Robert-Dehault
Hi,

Is there any reason atmosphere-runtime cannot run with a JRE 1.5 except
that java.util.ServiceLoader is used in org.atmosphere.di.InjectorProvider?

Thanks for your help.

--
Cordialement / Best regards,
Nicolas Robert-Dehault

Reply | Threaded
Open this post in threaded view
|

Re: atmosphere-runtime and JRE 1.5

Jeanfrancois Arcand-4
Salut,

On 11-05-09 7:18 AM, Nicolas Robert-Dehault wrote:
> Hi,
>
> Is there any reason atmosphere-runtime cannot run with a JRE 1.5 except
> that java.util.ServiceLoader is used in org.atmosphere.di.InjectorProvider?

Apology for the delay. I can probably pull out the DI stuff as a new
module so you can run it on 1.5. Will that works?

Thanks

-- Jeanfrancois


>
> Thanks for your help.
>
Reply | Threaded
Open this post in threaded view
|

Re: atmosphere-runtime and JRE 1.5

prodriguez
This post has NOT been accepted by the mailing list yet.
Salut,

One year later, a question about JDK 1.5 … again :-)

We have a project where JDK 1.5x is required and we would like to use Atmosphere (in WLS 9.2 with AbstractAsyncServlet as asynchronous API ). Clustering for performance, scalability, load balancing, failover … is critical … we would like to use Hazelcast for example … (no Redis because is a Windows based infrastructure).

Which version of Atmosphere can we use? … Obviously, we would like to use a recent/latest version.

Thanks,

Pedro
Reply | Threaded
Open this post in threaded view
|

Re: atmosphere-runtime and JRE 1.5

jfarcand
Administrator
This post has NOT been accepted by the mailing list yet.
*** wrong maillng list ***

   atmosphere-framework@googlegroups.com

Can you try 1.0.0-SNAPSHOT and report if that works or not? I think 0.7.2 is the only one that will work.

A+

-- Jeanfrancois
Reply | Threaded
Open this post in threaded view
|

Re: atmosphere-runtime and JRE 1.5

jfarcand
Administrator
This post has NOT been accepted by the mailing list yet.
In reply to this post by prodriguez
*** wrong maillng list ***

   atmosphere-framework@googlegroups.com

Can you try 1.0.0-SNAPSHOT and report if that works or not? I think 0.7.2 is the only one that will work.

A+

-- Jeanfrancois